I am getting a lot of email on that topic...

Securityimages 4.3.0 is working with Joomla! 1.0.15 and all previous version of Joomla! 1.0.x ONLY

Patches I've made for Joomla! 1.0.14 (patching Joomla! framework for login, register, lost email, administrator login) are also working for Joomla! 1.0.15.

It is the other way around, I have no version of securityimages 5.0 for Joomla!1.5 before the end of week... SecurityImages 5.0 will only work with Joomla! 1.5